Results 1 to 2 of 2
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    League City TX

    pump shaft insertion sl750

    I just replaced my thru hull shaft assemble and I am going back in with the shaft and pump, but the lip on the Ocean Pro ride plate will not let the pump housing to go back in? any ideas?

  2. #2
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Cleveland OH
    Something is off, take a close look at the pieces to see if something isn't aligned.

    If all is good, you can take a Dremel to the ride plate "rib" and grind a little to clear.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SL750 oil pump shaft removal
    By jsnyder11 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 08-26-2013, 04:54 PM
  2. sl750 pump shaft insertion?
    By skigolfnut in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-11-2009, 03:42 PM
  3. Ride Plate/Pump shoe Inserts
    By H204YOU in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-22-2006, 09:09 PM
  4. How to repair pump shoe inserts for intake grate...
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-18-2006, 09:31 PM
  5. Yamaha OEM Rideplate and Pump Shoe Inserts
    By spud in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 01-12-2006, 12:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts