Results 1 to 4 of 4
  1. #1
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33

    sl750 pump shaft insertion?

    I just replaced my thru hull shaft assemble and I am going back in with the shaft and pump, but the lip on the Ocean Pro ride plate will not let the pump housing to go back in? any ideas?


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    You see my pm with pics?

  3. #3
    Try to loosen the clamps on the thru hull fitting until after the pump is installed.

  4. #4
    skigolfnut's Avatar
    Join Date
    Jun 2009
    Location
    League City TX
    Posts
    1,979
    +1
    33
    I loosened the shaft hose clamps and it worked, thanks,

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 SL750 oil pump shaft removal
    By jsnyder11 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 08-26-2013, 04:54 PM
  2. pump shaft insertion sl750
    By skigolfnut in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-11-2009, 10:41 PM
  3. Ride Plate/Pump shoe Inserts
    By H204YOU in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 07-22-2006, 09:09 PM
  4. How to repair pump shoe inserts for intake grate...
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-18-2006, 09:31 PM
  5. Yamaha OEM Rideplate and Pump Shoe Inserts
    By spud in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 01-12-2006, 12:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •