Results 1 to 3 of 3
  1. #1
    Newb Under_Pressure's Avatar
    Join Date
    Jul 2009

    My new setup on my s2000

    Well it's done pics say it all:

    I changed the fuel system to use e85 ran dual walbros, 1600cc injectors, twin feed lines single return and a aeromotive reg.

  2. #2
    hard to tell with the camera but sounded like it was breaking a part a little bit but either way nice ride

  3. #3
    spelling police HAZE's Avatar
    Join Date
    Feb 2009
    Mase is the man. Its too bad he turned into a reverend and left Diddy. He killed it in "more money, more problems".

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My new setup
    By mohbaj007 in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-26-2011, 05:57 AM
  2. Guess the top speed.. with my new setup
    By rxp_kimmo in forum 4-Tec Performance
    Replies: 13
    Last Post: 08-02-2010, 12:37 PM
  3. TL Racing try the new setup
    By tobbe sweden in forum Videos & Pictures
    Replies: 0
    Last Post: 05-09-2010, 04:09 AM
  4. Trying my new setup this weekend
    By dduck1628 in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-06-2009, 01:54 PM
  5. Need more help w/ new setup
    By Turbo Nick in forum 4-Tec Performance
    Replies: 3
    Last Post: 04-30-2008, 02:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts