Results 1 to 6 of 6
  1. #1
    Gpr man now 9t8gp1200's Avatar
    Join Date
    Jul 2007
    Location
    N. KY
    Posts
    131
    +1
    1

    GPR water spout not working

    I got the GPR in the water and the signature Yami spout isn't working. I have the hose hooked up and everything...not sure why it's not shooting. Anyone ever had this problem?


  2. #2
    Stop staring at my tits NJJer's Avatar
    Join Date
    Jul 2008
    Location
    This house or that house
    Posts
    1,309
    +1
    1
    Quote Originally Posted by 9t8gp1200 View Post
    I got the GPR in the water and the signature Yami spout isn't working. I have the hose hooked up and everything...not sure why it's not shooting. Anyone ever had this problem?
    Nope. Most of us remove the Gay Spray right away.

    Is the hose clear?

    Is the fitting clear on the pump? On the spray nozzle?

  3. #3
    XL1200Ltd-Keith's Avatar
    Join Date
    Aug 2005
    Location
    Arizona
    Posts
    506
    It's either plugged, or a burst hose.

  4. #4
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    725
    +1
    4
    blue pill

  5. #5
    pilo704's Avatar
    Join Date
    Jul 2008
    Location
    dirty jerzz
    Posts
    830
    shoot some compressed air threw it bro

  6. #6
    Flying Scotsman's Avatar
    Join Date
    May 2006
    Location
    IllINOIS
    Posts
    6,514
    +1
    4
    I sugest removing it and JB weld it shut.
    Ever go through the no wake and the wind blows cold water back at you I have it sucks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. gpr 1200 yamaha speedometer not working
    By umpirepotts in forum Yamaha How To & FAQs
    Replies: 13
    Last Post: 04-11-2017, 04:21 PM
  2. Rear Pisser/Water Spout on my 800XL Stopped Working
    By NJFX4GT in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 09-17-2012, 11:08 PM
  3. Taking water, bilge not working??
    By armyguy7776 in forum Polaris Open Discussion
    Replies: 11
    Last Post: 06-10-2008, 09:19 PM
  4. okay, not work safe. Grossest picture I've ever seen...
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 07-19-2005, 09:31 PM
  5. Speedometer Not Working
    By jack in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-25-2005, 08:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •