Results 1 to 3 of 3
  1. #1
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6

    Am I in the ballpark with rpms?

    Ok, after drowning a tach(pet2500) and getting a new one on one month later, I am turning 7020 + or - 20 in 95-100 degree heat/humidity (around 70-72mph). This is stock 14/20 dynafly prop 05 pump. plugs looked like I was running rich.

    Do those numbers seem reasonable in that heat? I haven't messed with adjusting carbs yet, plus I can't get my bear claws down there. I am reading up on carb tuning threads any pointers?
    Thanks for the all the great info, minimal work and $ got me great speed
    Thanks
    Doug Hoad


  2. #2
    big83bronco's Avatar
    Join Date
    May 2006
    Location
    Macon, GA
    Posts
    326
    yea, that seems liek a good speed for the rpm's and prop. Your rpm's a re a bit low for peak (peak starts at about 7100-7250). By th way that 14/20 prop you sold me is great. I just got to get my RPM's up and get my pump shoe set up right!

  3. #3
    dhoad's Avatar
    Join Date
    Aug 2005
    Location
    North Aurora, Illinois, United States
    Posts
    3,182
    +1
    6
    glad the prop worked well for you big83.
    Anyone with input on carb tuning/rpms/ etc.? info greatly appreciated!

    does anyone know of a source for a permanent attachment for t-handle adjusters with extension type device. I slotted a blade screw driver and still can hardly reach t-handles on carbs. I was thinking of a device like a flexible drill/driver would be perfect

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 09-26-2015, 07:50 AM
  2. Replies: 11
    Last Post: 06-01-2010, 11:48 PM
  3. I am finaly in the 70mph Club
    By Ultra250xryder in forum Kawasaki PWC Performance (4-stroke)
    Replies: 23
    Last Post: 11-20-2007, 10:20 AM
  4. anyone in central TX with a open trailer spot to the mudbug
    By rapidacceleration in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-01-2006, 09:56 PM
  5. Am I in the wrong?
    By Yuji in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 05-17-2006, 05:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •