Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Waterproof your powershot & new intercooler pics

    quick and easy way to waterproof the powershot...I used to do this on my rc car parts. just a balloon and a zip tie.

    pwr intercooler...4x8
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_1267.jpg 
Views:	58 
Size:	2.41 MB 
ID:	141297   Click image for larger version. 

Name:	IMG_1245.jpg 
Views:	88 
Size:	1.89 MB 
ID:	141298   Click image for larger version. 

Name:	IMG_1244.jpg 
Views:	67 
Size:	1.96 MB 
ID:	141299  


  2. #2
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Ooooo. PWR is nice stuff. Any reason you went with it over just a XS style? Better fitment?

  3. #3
    just to try something new...I thought that shobiz originally had some issues with the type 19.

    I have recently lost rpm and my ski is only running like 63 I am not sure why. but i think that I may have bent my prop when I changed the clutch...because I am an idiot and tried to hold the shaft by jamming something in the impeller really dumb idea on my part but I wanted to get done. thats when I lost the rpm.

    I dont have the gauges or sensors to report on intake temps but hope to soon and will post results.

  4. #4
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by allstar71 View Post
    quick and easy way to waterproof the powershot...I used to do this on my rc car parts. just a balloon and a zip tie.

    pwr intercooler...4x8

    Gosh that IC looks familar to someone elses being sold

  5. #5
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by SHOBiz View Post
    Gosh that IC looks familar to someone elses being sold
    I just noticed that too. R&D's look exactly the same. No wonder they are so much more expensive. The PWR cores are PRICY. Well that and R&D makes it a kit.

    You only had issues with your type 20 right, which at the time you were testing you believed to be a type 19?

    Man... I have not had any issues with my frozeboost IC. But then again I haven't really put it to the test under higher boost levels and proven it's efficiency. Oh well. Still can't beat the price.

  6. #6
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by hitman View Post
    I just noticed that too. R&D's look exactly the same. No wonder they are so much more expensive. The PWR cores are PRICY. Well that and R&D makes it a kit.

    You only had issues with your type 20 right, which at the time you were testing you believed to be a type 19?

    Man... I have not had any issues with my frozeboost IC. But then again I haven't really put it to the test under higher boost levels and proven it's efficiency. Oh well. Still can't beat the price.

    The hole type 20, type 19 thing Ugh...

    What issue did I have ?

    There was a boost problem that turned out to be an electrical thing. Can't remember anything else. I have the type 20 back in an run the holy tar out of it.

  7. #7
    hitman's Avatar
    Join Date
    Aug 2006
    Location
    Ft. Lauderdale, FL
    Posts
    4,328
    +1
    12
    Quote Originally Posted by SHOBiz View Post
    The hole type 20, type 19 thing Ugh...

    What issue did I have ?

    There was a boost problem that turned out to be an electrical thing. Can't remember anything else. I have the type 20 back in an run the holy tar out of it.
    You had the issue of thinking it was dropping pressure across the core. That's what I was refering to. Not sure which issue Allstar was under the impression you had, but I know you had trouble with it, and never definitively said whether or not you liked it or didn't, or fixed the issue.

    So, your type 20 is back in and giving you good results?

  8. #8
    SHOBiz's Avatar
    Join Date
    Jul 2008
    Location
    Wylie, Texas
    Posts
    3,577
    Quote Originally Posted by hitman View Post
    You had the issue of thinking it was dropping pressure across the core. That's what I was refering to. Not sure which issue Allstar was under the impression you had, but I know you had trouble with it, and never definitively said whether or not you liked it or didn't, or fixed the issue.

    So, your type 20 is back in and giving you good results?

    So far yes! Also, insulated the IC now.

    On a good day even with 100*F I have logged 12psi @8,000rpm momentarily on the C3. Typical at WOT in this heat is 11.3psi if the IC is not heat soaked. I watch the boost gauge and if it is hot it reads about -8.6 @idle, I wait until I see -9.1 again before I run.

    How's this (from this last Saturday):

    100*F Air Temp
    ???*F Water Temp
    Before I/C 240*F
    After I/C 105*F


    On a previous ride arounf 6/25 I logged:
    99*F Air Temp
    86*F Water Temp
    Before I/C 259*F
    After I/C 113*F

    Get to see how it holds up to the Riva E1 Wheel soon.

  9. #9
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32
    Quote Originally Posted by SHOBiz View Post
    So far yes! Also, insulated the IC now.

    On a good day even with 100*F I have logged 12psi @8,000rpm momentarily on the C3. Typical at WOT in this heat is 11.3psi if the IC is not heat soaked. I watch the boost gauge and if it is hot it reads about -8.6 @idle, I wait until I see -9.1 again before I run.

    How's this (from this last Saturday):

    100*F Air Temp
    ???*F Water Temp
    Before I/C 240*F
    After I/C 105*F


    On a previous ride arounf 6/25 I logged:
    99*F Air Temp
    86*F Water Temp
    Before I/C 259*F
    After I/C 113*F

    Get to see how it holds up to the Riva E1 Wheel soon.
    cant wait to see how the riva wheel compares

  10. #10
    krenzema's Avatar
    Join Date
    Aug 2007
    Location
    Houston - Sarasota
    Posts
    215
    Quote Originally Posted by SHOBiz View Post
    On a good day even with 100*F I have logged 12psi @8,000rpm momentarily on the C3.

    Get to see how it holds up to the Riva E1 Wheel soon.

    SHOBiz,
    What’s your max RPM with the C3 and 13/24?
    Where do you think the E1 & 13/24 will put you?

    I’m curious as to what WOT RPM the SHO motor will be happiest at over time? 7,700… 8,000… 8,300…

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New intercooler install
    By HoopsRXT in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-06-2007, 08:17 PM
  2. New Seat pics Color added
    By mikegpr03 in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 03-18-2007, 06:32 AM
  3. New 2007 pics/vids. Anyone selling Gpr-RXp?
    By JordanHaye in forum Conversion PWC Performance Skis
    Replies: 14
    Last Post: 01-29-2007, 11:59 PM
  4. Hey Shibby too bad your ski isnt running - Some pics for you
    By J3ff in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 06-22-2006, 06:35 PM
  5. New Hood Pics
    By 1 FAST VE in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-21-2005, 08:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •