Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    SLT750 loses power over 5000rpm

    Here's the issue. I can cruise between 4000 - 4500RPM, but when I give it gas >5000rpm, it runs for about 5 - 15seconds, then I lose power. When I feel it hesitating, if I let go of the throttle, the engine will continue to run while I slow down, then I can accelerate again. If i keep on the gas, the engine cuts out and requires me to pull the choke to start up again. I have been troubleshooting a fuel supply issue. I have cleaned out the fuel/water seperator, replaced the fuel filter and it continues to happen. I am not a mechanic, but pretty handy.

    Question- I can see that the fuel filter has air inside, is is supposed to, or should it be completely full of fuel?

    Any other thoughts?


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Welcome

    Click below for the service manual.

    And have a look here;
    Polaris Fuji (blue) engine

    Is this machine new to you?

    Has it ever run properly for you?

    Do you have original gray Tempo fuel lines installed?

    I suspect you need to change all the fuel lines (including those inside the fuel tank), then remove, dis-assemble, and rebuild the carb(s).

    Also check and clean the fuel selector valve.

    Replace the fuel filter and/or clean the fuel/water separator.

    Make sure the correct spark plugs are installed.

  3. #3
    It is new to me, but been in the family. It has run properly in the past, yet has sat idle for a year. I took out and replaced the fuel.
    I will have to check on the fuel lines.
    I have cleaned the seperato, and installed new plugs. I will be working on it this afternoon, and update tomorrow.
    Thanks.

  4. #4
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    Is the engine hot when you touch it?

    Does it shut right off or kinda bogs out and dies?

  5. #5
    The engine does not seem overly hot. I would say that it bogs down, then if I keep the throttle open, it dies, but if I feel the hesitation and release the throttle, it will keep running.

  6. #6
    Today I removed the gas tank assembly and inspected the intank components. There is no sediment in the tank, and everything looked really clean. I again cleaned out the fuel water seperator which had no water in it. I had replaced the spark plugs, the other day, yet pulled them tonight and rechecked the gap. They seemed a little bit dirty. The fuel lines were replaced about 2 years ago. When looking at the fuel selector valve, the saltwater had corroded the under knob parts. The knob was cracked and spinning. I am not sure what position the valve is in. I am going to order a new one. Is there any issues with a short term bypass of the valve? If I put in a T between the tank and the seperator, and cap off the res line? Unfortunately the valve is not available at my local dealers, so I will be ordering it online.

  7. #7
    Any idea where I can buy a new selector valve? Dealers do not have them, can't find them on 4-tec?

  8. #8
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,329
    +1
    31
    You can install a Sea Doo fuel valve. It will bolt right up, but the positions will be off.

    Nothing big.

    You can bypass the valve for now to see if that helps solve your problem. But would want to install a valve to prevent issues.

    Have you inspected the in-line fuel filters if you have them?

    Have the internal carb filters been inspected?

    Did you verify carb settings are good?

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,584
    +1
    1,272
    Quote Originally Posted by petrica98 View Post
    Any idea where I can buy a new selector valve? Dealers do not have them, can't find them on 4-tec?
    Where can I get a replacement fuel selector valve (On-Off-Reserve)?
    The Polaris selector valve is no longer available, but the 1995 Yamaha Wave Blaster Fuel Selector valve may be a good replacement
    6K8-24500-02-00

    From this web page;
    Polaris Fuji (blue) engine

  10. #10
    Quote Originally Posted by xlint89 View Post


    Did you verify carb settings are good?
    I have not, but will shortly. How do you guys feel about running Seafoam through the engine? Will that

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Genesis Ficht loses power momentarily when ski gets water over it?
    By Inssomniak in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-22-2016, 12:52 AM
  2. Losing Power
    By nobbyq in forum Yamaha Open Discussion
    Replies: 4
    Last Post: 10-03-2007, 04:20 PM
  3. Engine intermittantly balks over 5000RPM
    By fdesorme in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 07-22-2007, 11:45 AM
  4. 250 is losing power
    By mooneyb91084 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-17-2007, 09:29 AM
  5. accessories intermitently losing power
    By Bamafanatic in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-22-2007, 11:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •