Results 1 to 5 of 5
  1. #1
    region8racer's Avatar
    Join Date
    Jan 2007
    Location
    Cherry Hill, NJ
    Posts
    83

    Help 04 Rxp wont start

    I was out riding all day yesterday with no problems. Everything was good till i went to start her up from the beach and i got nothing. I heard what sounded like the fuel pump kick in but i wasnt getting any reading from the cluster. No beeping, not anything. Can anyone give me some advice!!!


  2. #2

    Join Date
    Jul 2007
    Location
    Cleveland, Ohio
    Posts
    43
    Try cleaning the terminals on the battery. Same thing happened to me over the weekend. The fuel rail would pressurize but I would not get a DESS tone and the ski would not fire. Cleaned the terminals with some steel wool and it fired right up. Im pretty sure our ignition system runs off of the battery, hence the reason the ski will stutter and miss if the battery is not properly charged.

  3. #3
    Bow chicka wow wow
    Join Date
    Sep 2006
    Location
    Charlotte,NC
    Posts
    490
    +1
    5
    Quote Originally Posted by region8racer View Post
    I was out riding all day yesterday with no problems. Everything was good till i went to start her up from the beach and i got nothing. I heard what sounded like the fuel pump kick in but i wasnt getting any reading from the cluster. No beeping, not anything. Can anyone give me some advice!!!
    Sounds like another starter solenoid. It's right beside the MPEM box, light brown. I'm on my 2nd-06 RXP. I am assuming everthing else is ok, battery, etc.

  4. #4
    region8racer's Avatar
    Join Date
    Jan 2007
    Location
    Cherry Hill, NJ
    Posts
    83
    ttt

  5. #5
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,931
    +1
    1,407
    What is the battery voltage measured with a meter at the battery while pushing the start button.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 rxp wont start! help!
    By kjv86' in forum Open Discussion
    Replies: 3
    Last Post: 07-29-2013, 01:06 PM
  2. Replies: 4
    Last Post: 07-09-2011, 06:50 PM
  3. Help 04 Rxp wont start
    By region8racer in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-17-2009, 11:40 PM
  4. stage 3 kit 04 rxp wont spin no more than 6800 help
    By Extrememotors in forum 4-Tec Performance
    Replies: 26
    Last Post: 05-29-2008, 05:55 AM
  5. RXP wont start
    By werdnash2002 in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-21-2005, 11:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •