Results 1 to 9 of 9
  1. #1

    spx water in motor

    i last used my ski july 4th try to run it today found out i had water in cylinders removed plugs and water out now it starts up fine anything else i should do? could it be rusted after a week?


  2. #2
    flyin' the friendly skies airbornexp's Avatar
    Join Date
    Aug 2007
    Location
    Mahomet, Il. USA
    Posts
    6,004
    +1
    163
    test your compression. If that was me i would have cranked the water out, changed the plugs, and restarted ASAP. if it still runs fine Id say that your pretty lucky

  3. #3
    i just did a compression test both cylinders came out to 150 each what should be at new? also how does water get into the cylinders?

  4. #4
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by mikeymuy View Post
    i just did a compression test both cylinders came out to 150 each what should be at new? also how does water get into the cylinders?
    By the last person that rode it. Obviously you don't start your engine when on the trailer after pulling it out for the day, and blow out the residual water in the pipe and waterbox, otherwise you would have found it that day.

    I would fog the engine thouroughly and hope for the best. Normally water left in an engine longer than a day results in a new crank and c/b shaft replacement.

    I'll keep my fingers crossed for you!

  5. #5
    lextoy's Avatar
    Join Date
    Jan 2007
    Location
    Brigantine, NJ
    Posts
    1,883
    +1
    14
    150 each is good, thats what its supposed to be 150-160.

  6. #6
    on my way out to the lake i was told to add some oil in gas to extra lube hope it rans good thanks guys

  7. #7
    well i just got back and it ran fine rode for two hours hope its all good time will tell thanks for all the tips

  8. #8
    96XPSS's Avatar
    Join Date
    Feb 2006
    Location
    Warner Robins, GA Home of the 2007 All-Star Little League World Champions!
    Posts
    4,361
    Quote Originally Posted by mikeymuy View Post
    well i just got back and it ran fine rode for two hours hope its all good time will tell thanks for all the tips
    Fog it after the first 4 rides.

    We'll keep our fingers crossed for you!

  9. #9
    what if i fog it right now? just spend in the cylinders right?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Water in motor - 97 XP 787
    By skidooosl in forum 2-Stroke Performance
    Replies: 5
    Last Post: 07-07-2008, 11:20 AM
  2. Water in motor, help!
    By GP1300RnPVB in forum Yamaha PWC Performance (2-stroke)
    Replies: 25
    Last Post: 08-06-2007, 09:12 PM
  3. Water in motor
    By billywilly in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-04-2007, 07:45 PM
  4. Water in motor
    By explude in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 06-18-2007, 07:56 PM
  5. 95 SPX Water in Hull
    By 95 sl750 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 05-11-2007, 10:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •