Above Forum Ads

Collapse

Announcement

Collapse
No announcement yet.

Polaris SLX1200 Rescue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Polaris SLX1200 Rescue

    New to the forum. Based in the UK. Picked up my first ski a couple of months back - a running but very tatty 2000 SLX1200.

    I don't know much about jet skis but am quite experienced with projects of a similar nature having rebuilt a few motorbikes over the years. Not had much to do with 2 strokes either, but again have a bit of understanding from tinkering and reading.

    The ski looks to have had a pretty tough life, but not having seen any others I don't know how it compares to a similar age and hour machine. The hull has got a few marks on the bottom, but no major impacts or damage so hoping that I can repair, fill and re paint the bottom of the hull.

    Engine wise, it starts and runs fine but has been sat for a while. Upon doing a compression test, my PTO cylinder is down on compression (80psi) vs a healthy 130psi in the centre and mag cylinders. So no doubt it will need a top end kit. I suspect the crank seal has gone and it's run lean. Cant be too bad if if still runs on that cylinder though (famous last words).

    I stripped the jet pump off for rebuild and was greeted with some pretty serious carnage. It has the SS 6 vane stator and SS factory wear ring (which looks in reasonable condition) and factory 202 prop on it which has also seen better days.

    As spares over here are non existent, I had a friend of mine repair the chewed up stator and it came out pretty good.

    I also refinished the prop as best I could, although the clearance to the housing is on the larger side. I'm going to remeasure once the stator is all back together and see where we are at. If anyone has a 707 prop in good condition they are willing to ship to the UK, let me know.

    The wear ring is currently stuck on the ski, so any tips on how to remove it would be appreciated!

    Luckily the drivehsaft and impeller shaft are in good condition, despite the seals being complete toast on both. The jet pump was full of water (as I'm sure they all are at this age when not been rebuilt) but luckily the bearings still turned. New ones are on the way, as I ordered 6304 2RS, not realising these were C3 bearings.

    For the impeller shaft I measured the old o rings and ordered some replacements, but not 100% sure if these are right or not. As I needed a new tail cone seal I ordered the OEM parts to compare dimensions. As the OEM ones weren't expensive, I'll fit them and keep the others for spares if they are indeed correct.

    I will need to pull the engine for a rebuild. Also planning toreplace fuel lines/ oil lines and go through everything. All electrical connectors, cables etc to get this thing running sweet and reliably.

    Hope you enjoy the thread.

  • #2
    Pics below
    Attached Files

    Comment


    • #3
      More pics
      Attached Files

      Comment


      • #4
        Nice one mate canÔÇÖt wait to see the end of it

        Comment


        • #5
          Okay updates below. Ended up buying another ski, in mint condition but the engine was locked up. I figured worst case I could make one good ski out the two. I'll let the pictures talk.


          Comment


          • #6

            Comment


            • #7
              Usual jet pump corrosion was binding on the impeller - however not the cause of the engine being locked up.

              Comment


              • #8
                Slight misshap with the trailer - axle rusted through. New axle on order - lead time 6 months!

                Comment


                • #9
                  Started stripping out the engine bay to remove the engine for a rebuild. Could not get the crank to turn, even with the driveshaft removed. Expecting internal carnage.

                  Comment


                  • #10
                    Salt water ski so lots of corrosion on everything.

                    Comment


                    • #11


                      Issue found.

                      Comment


                      • #12

                        Comment


                        • #13

                          Comment


                          • #14
                            So the photos above are all from the black ski.

                            Crank was toast - even though it had been rebuilt in the past, the wrong bearings had been used. Someone had gone to the effort of rebuilding it using 62072RS bearings - not even a clearance fit! I think I have seen it all now.

                            Cylinders were also scored up pretty bad even though the pistons and rings looked in good shape. One piston was damaged in the ring grove but 2 will go again (more on that later). I was expecting this as I found the oil pump feed pipe badly kinked and the oil pump body itself damaged, as well as the white drive coupler on the end of the crank all chewed up. It looks like someone fitted the oil pump without lining the tag on the pump up and then ran the engine after it was rebuilt. I think what then happened was that when it was next started, it seized on the crank bearings not being the correct clearance fit which prevented a complete piston meltdown.

                            So 3 new O/S genuine Polaris pistons ordered, including a complete genuine Polaris rod and bearing set for the crank. About ?ú800's worth of parts there alone.

                            Work then started on the white ski and engine - I knew this one had low compression on one of the cylinders but did not know any other history. Cosmetically and from the state of the impeller it was clear this ski was beached quite regularly. However other than that once I started taking it apart I realised that other than the shitty paint job on top of the engine, the ski had never been touched or apart.

                            Pictures are now from the white ski.

                            Comment


                            • #15

                              Comment

                              Working...
                              X