Above Forum Ads

Collapse

Announcement

Collapse
No announcement yet.

Seadoo RXP 260 speed issue and impeller advice

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Seadoo RXP 260 speed issue and impeller advice

    Hi guys, I’m new to this forum and new to owning a jetski.

    Issue I’m having with the ski is that the top speed maxes out at 105km/h (65mph), I’ve read these should do 115km/h (70mph)ish. I’ve replaced the wear ring with a brand new oem one and still has the same top speed. While looking into the back of the jet pump with the IBR up I can see some slight wear on the trailing edge of the impeller, and a few burrs while looking into the intake grate from under the ski on the leading edge, would this cause low top speeds? Also noticed that one of the stator vanes on the pump housing has a chunk missing (attached photo) and also some pitting next to each vane. Would this cause speed issues and have to be replaced or is it quite common? I’m also looking to replace the worn impeller with a new OEM unit or with a Solas 15/20, Would this solas suit a relatively stock ski with a stock untuned ecu, 4” intake, catch can and aftermarket intercooler? Don’t want to loose speed or rpm. Ski has 117hrs on it and revs great to 8040rpm and holds there. On holeshot it hits the rev limiter a few times before coming onto plane and taking off, not sure if it’s cavitation or if this is just what they do.
    Thanks!

    Edit: 2014 seadoo Rxpx 260 RS, so doesn’t have the USCG speed limit.
    Attached Files
    Last edited by LJ99; 02-03-2023, 09:11 PM.

  • #2
    It sounds like you have an air leak in the intake tract of the pump if you're repeatedly hitting a "high" RPM on launches. Does the intake side of the impeller (when looking through the grate) have wear on the edges? I don't think the nick on the trailing edge of the impeller is causing your symptom-it looks like a rock was pinched between one of the blades and stator vane. If this damage is severe it may explain your loss of top speed, though.
    2018 GTR-X 230
    2004 STX-15F race ski revived in 2016
    1998 GTX-RFI-original owner

    Comment


    • #3
      Originally posted by pro1200 View Post
      It sounds like you have an air leak in the intake tract of the pump if you're repeatedly hitting a "high" RPM on launches. Does the intake side of the impeller (when looking through the grate) have wear on the edges? I don't think the nick on the trailing edge of the impeller is causing your symptom-it looks like a rock was pinched between one of the blades and stator vane. If this damage is severe it may explain your loss of top speed, though.
      Replace the pump seal. I put 3m windshield sealant on the new pump seal around the inside & outside edge. Next remove that stainless wearing. I just use a carbide bit and cut them out. Install new plastic wearing. Then send your prop to Impros & have it repaired. Install & ride.

      Comment


      • #4
        Originally posted by LJ99 View Post
        revs great to 8040rpm and holds there. O
        Your ski is on the rev limiter and this is why your speeds are low. You need to upgrade to this Solas 15/22R
        Solas Concord Impellers increase low-end thrust and top-end speed. Constructed of high strength stainless steel, Solas Impellers feature a polished hub and exclusive hub-end water seal for reduced cavitation. All "R" model Solas impellers are placed in a pitch-block before leaving Solas to ensure accuracy for optimal performance. Available only from RIVA Racing and RIVA Authorized Dealers!


        It would also help to replace your pump as from what I see, the vane's have been eroded from cavitation burn. You will find factory replacement parts in the GreenHulk Store.
        Save money on your pwc performance parts! Use the discount code: greenhulk when completing the checkout process in the GREENHULK PWC Performance Store and save 10% off the listed price of MOST Riva Racing and ALL WORX Racing Products. We also offer Fizzle Racing, MaptunerX tuning bundle packages, and instant download tuning licenses at discounted prices.

        Shop now! www.greenhulkstore.com​​
        Contact us! [email protected]
        Like us on Facebook! www.facebook.com/GreenHulkPWCPerformanceStore

        Comment


        • #5
          Replace the jet pump with a new one. Its worn out.

          Comment


          • #6
            Originally posted by pro1200 View Post
            It sounds like you have an air leak in the intake tract of the pump if you're repeatedly hitting a "high" RPM on launches. Does the intake side of the impeller (when looking through the grate) have wear on the edges? I don't think the nick on the trailing edge of the impeller is causing your symptom-it looks like a rock was pinched between one of the blades and stator vane. If this damage is severe it may explain your loss of top speed, though.
            Originally posted by Green Hulk View Post
            Your ski is on the rev limiter and this is why your speeds are low. You need to upgrade to this Solas 15/22R
            Solas Concord Impellers increase low-end thrust and top-end speed. Constructed of high strength stainless steel, Solas Impellers feature a polished hub and exclusive hub-end water seal for reduced cavitation. All "R" model Solas impellers are placed in a pitch-block before leaving Solas to ensure accuracy for optimal performance. Available only from RIVA Racing and RIVA Authorized Dealers!


            It would also help to replace your pump as from what I see, the vane's have been eroded from cavitation burn. You will find factory replacement parts in the GreenHulk Store.
            Originally posted by LJ99 View Post
            Hi guys, I'm new to this forum and new to owning a jetski.

            Issue I'm having with the ski is that the top speed maxes out at 105km/h (65mph), I've read these should do 115km/h (70mph)ish. I've replaced the wear ring with a brand new oem one and still has the same top speed. While looking into the back of the jet pump with the IBR up I can see some slight wear on the trailing edge of the impeller, and a few burrs while looking into the intake grate from under the ski on the leading edge, would this cause low top speeds? Also noticed that one of the stator vanes on the pump housing has a chunk missing (attached photo) and also some pitting next to each vane. Would this cause speed issues and have to be replaced or is it quite common? I'm also looking to replace the worn impeller with a new OEM unit or with a Solas 15/20, Would this solas suit a relatively stock ski with a stock untuned ecu, 4ÔÇØ intake, catch can and aftermarket intercooler? Don't want to loose speed or rpm. Ski has 117hrs on it and revs great to 8040rpm and holds there. On holeshot it hits the rev limiter a few times before coming onto plane and taking off, not sure if it's cavitation or if this is just what they do.
            Thanks!
            Do as it says in post #2 and #4. In addition, replace the carbon seal, bellows, C clip, and floating ring, aka Hat. That said, first order of things to do is to properly realign the engine to thur hull fitting to pump.

            Concerning wear rings: Use the stainless steel one. The key to its use is a properly pitched and blueprinted/balanced impeller. If hand pitching impellers (DIY), then use a plastic wear ring. All the parts mentioned are available at the GH store.
            2013 RXT-X260 - GRF BorgWarner EFR 67/58 Turbo/MoTeC M130
            Build Thread: http://www.greenhulk.net/showthread.php?t=231361
            Kicker audio:http://www.greenhulk.net/showthread.php?t=215264&highlight=kicker
            https://wfoperformance.net/sites/us/...5/web/home.htm

            Comment


            • #7
              Originally posted by 1tommygunner1927 View Post
              Do as it says in post #2 and #4. In addition, replace the carbon seal, bellows, C clip, and floating ring, aka Hat. That said, first order of things to do is to properly realign the engine to thur hull fitting to pump.

              Concerning wear rings: Use the stainless steel one. The key to its use is a properly pitched and blueprinted/balanced impeller. If hand pitching impellers (DIY), then use a plastic wear ring. All the parts mentioned are available at the GH store.


              Hi guys, thanks for all the replies. In regards to the air leak in the intake tract when I did the new plastic wear ring I fitted and new neoprene pump seal as well but also no change in launch rpm or top speed. There are some small burrs/chips on the leading edge of the impeller not sure if that'll affect performance (attached photo). I understand the ski is on the limiter (8040) but something would have to be worn to not achieve stock top speeds. For the impeller will the Solas 15/22r be good for a ski with stock limiters? I've read it could be too much prop and some people loosing rpm/speed. Any input on this would be appreciated. I'll also look into getting a new jet pump if the wear seems excessive on it.
              Thanks!
              Attached Files

              Comment


              • #8
                Quick update: I’ve pulled the pump back off and the part number on the impeller is 267000648 which has been superseded by 267000757 which is an impeller assembly off a 2013 GTR 215? Are they the same impellers or has someone put the wrong impeller in this machine?

                thanks

                Comment


                • #9
                  215 255 260 230 are all the same jet housing

                  Comment


                  • #10
                    Originally posted by tiderider View Post
                    215 255 260 230 are all the same jet housing
                    Is impeller pitch all the same?

                    Comment


                    • #11
                      No, all different

                      Comment


                      • #12
                        Originally posted by tiderider View Post
                        No, all different
                        yeah I thought so, what I’m saying is that there seems to be a 215 impeller in my 260. I’m guessing that’d cause some of the issues I’m having with speed loss or should it still get up to speed the same?

                        thanks

                        Comment


                        • #13
                          Originally posted by Green Hulk View Post
                          Your ski is on the rev limiter and this is why your speeds are low. You need to upgrade to this Solas 15/22R
                          Solas Concord Impellers increase low-end thrust and top-end speed. Constructed of high strength stainless steel, Solas Impellers feature a polished hub and exclusive hub-end water seal for reduced cavitation. All "R" model Solas impellers are placed in a pitch-block before leaving Solas to ensure accuracy for optimal performance. Available only from RIVA Racing and RIVA Authorized Dealers!


                          It would also help to replace your pump as from what I see, the vane's have been eroded from cavitation burn. You will find factory replacement parts in the GreenHulk Store.
                          I'm looking at getting a new SBT replacement pump and a new impeller. Will the 15/22 you recommended still allow the ski to reach full rpm? (8040 stock limit) Or will a 15/21 or 15/20 suit better? I'm very new to impellers and how the pitch works but also want to get as much advice as possible before spending the money.
                          thanks

                          Comment


                          • #14
                            15/21 is for your model stock.
                            Will it reach full rpm? Depends. Is the engine running properly, with good compression. Do you have leaky valves? Are you riding in high elevations? Is the water cool, cold, warm or hot? Same with the air temperatures and humidity?

                            Comment


                            • #15
                              Got it yet?

                              Comment

                              Working...
                              X